Comcast Login

Video demonstration and instructions on how to use the Comcast Login:

Follow These Steps to access your account:

1. First Enter the Comcast Login address or URL into the address bar of your browser:

https://login.comcast.net/login?forceAuthn=1&continue=%2fSecure%2f&s=ccentral-cima&r=comcast.net

2. Then on the empty text field under EMAIL OR USERNAME, enter your Username or your Email Address

3. Next on the empty text field under PASSWORD, enter your Password

4. Click or tick off the box next to KEEP ME SIGNED IN so you don’t have to sign in each time you access your account

5. Then you have to type in the letters/numbers on the CAPTCHA key

6. Make sure you check your credentials as most login pages are case-sensitive

7. Finally, click the SIGN IN button to proceed to your account

 

Are you having trouble logging in?

If you're still having trouble logging in, you can follow these steps to retrieve or reset your USERNAME and PASSWORD.

1. Under the text field of the Email Address/Username, click the link that says DONT KNOW YOUR EMAIL OR USERNAME? 

2. Then follow the instructions there and provide the needed information to retrieve or reset your Username. You can confirm your identity by entering information about your billing address (including account number, street address and phone number) or entering the last four digits of your Social Security. Then click on the button that says LOOK IT UP to look up your Username/Email Address

3. If you still cannot log-in, under text field of the Password, click the link that says FORGOT PASSWORD? 

4. Follow the instructions there and provide the needed information to retrieve or reset your Password. In this case, you will have to enter in your Username or Email address. Then click on the NEXT button to reset or retrieve your Password

Still having trouble logging in? No worries, simply contact Comcast directly and get help with your Comcast Login:

Agents are available by phone 24/7.

1-800-XFINITY (1-800-934-6489)

Or visit their forums and find a similar problem at:

http://forums.comcast.com/